Summary:
An error about circular logging references an MS Exchange backup that is failing because the feature for "Circular Logging" is enabled by default on many Exchange Servers.
Applies to:
OS: Windows Server 2003 & up
Backup Set Type: MS Exchange Server Backup
Backup Manager version: 5.X.X.X & up
Description & Background:
Circular logging was introduced in the early versions of Microsoft Exchange as a method for conserving disk space. It prevents Exchange transaction logs from using up very much hard disk space by limiting the number of transaction logs in use at any given time. In most cases, only four 5MB transaction logs are used at a time with this feature enabled. This poses an issue with incremental and differential backups as it becomes impossible to maintain these logs as part of the backups when they are constantly being re-used. Since disk space is less of an issue these days, circular logging is almost never required, yet is still often enabled by default, especially in SBS editions of Windows Server.
When performing a MS Exchange transaction log backup, the following error message is received in the backup report:
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Cause:
The message suggests that a transaction log backup cannot be performed if the corresponding information store has circular logging enabled.
Resolution:
To resolve this, disable circular logging and restart the Microsoft Information Store service.
For Exchange 2003 (version 6.5.xxxx.x)
1) Open the Exchange System Manager
2) Expand Servers
3) Expand the [Server Name]
4) Right click on First Storage Group and choose properties
5) Remove the check mark for “Enable circular logging” as shown below
6) Restart the “Microsoft Exchange Information Store” service.
Note: 'Log file' backups will continue to fail until the next 'database' backup is successful.
Screenshot from Exchange 2003 with "Circular Logging" disabled.
For Exchange 2007 / 2010
1) Open the Exchange Management Console
2) Expand "Server Configuration
3) Select "Mailbox"
3) Choose the appropriate Server listed in the top center pane.
4) Right click on each applicable storage group in the bottom center pane and choose properties
5) Remove the check mark for “Enable circular logging” as shown below
6) Restart the “Microsoft Exchange Information Store” service.
Note: 'Log file' backups will continue to fail until the next 'database' backup is successful.
Screenshot from Exchange 2003 with "Circular Logging" disabled.
See Also:
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