Product Version:
ocBackup Manager: All
OS: Windows (MS Exchange 2010)
OS: Windows (MS Exchange 2010)
Problem Description:
When performing a MS Exchange 2010 server backup, the following error message is received in the backup report:
|
Note:
This issue may occur for Windows Server with MS SQL, SharePoint Foundation 2010 Service Pack 1, or Windows SBS 2011 as MS SQL and SharePoint 2010 are included with this operating system.
This issue may occur for Windows Server with MS SQL, SharePoint Foundation 2010 Service Pack 1, or Windows SBS 2011 as MS SQL and SharePoint 2010 are included with this operating system.
Cause:
This error can occurs if one of the following conditions are met:
- There is a problem with the Volume Shadow Copy service.
- Circular logging is enabled for the mailbox store selected for backup.
- For server with MS SharePoint Foundation 2010 Service Pack 1 or Windows SBS 2011, the service pack update process maybe incomplete.
- For server with MS SQL, there maybe conflict with the SQL Server VSS Writer service.
Resolution:
Open the Event Viewer snap-in on the affected machine, under the 'Application' tab, check for any Volume Shadow Copy error at the time of the backup.
Also, try cleaning up the VSS snapshots on the affected server:
- Check on the VSS writers, open an Administrative command prompt and enter the following commands -
>vssadmin list writers
This should output a list of writers and their status, they should all be reported as stable. - If there is writer listed at unstable, please re-register the Volume Shadow Copy Service by following the instructions below -
- Download the 'RegisterVSS2010.zip' file by Clicking Here.
- Extract the zip file/.
- Execute the extracted script file.
- Reboot the machine.
Also, try cleaning up the VSS snapshots on the affected server:
- Open an administrative command prompt and enter the following commands -
>vssadmin delete shadows /all
This will clean up any dead VSS snapshots, some defect system may accumulate hundreds of VSS snapshots that persist in the system and cause Windows to become un-responsive. - On some systems, the command 'vssadmin delete shadows' may not be available. For these cases, open an administrative command prompt and enter the following commands -
>vssadmin Resize ShadowStorage /For=C: /On=C: /MaxSize=300MB - If there is no VSS writer error shown, but the system is not creating a new VSS snapshot, you may have to actually increase the max shadow storage size on your system -
Open an administrative command prompt and enter the following commands -
>vssadmin Resize ShadowStorage /For=C: /On=C: /MaxSize=10GB
Check if circular logging is enabled for the corresponding information store. If it is, try disabling the circular logging option and restart the "Microsoft Exchange Information Store" service afterward.
Perform a full MS Exchange server backup instead of transaction log backup straight after disabling circular logging. This would ensure that the data on the backup server isbacked up properly.
Next, to confirm if the SharePoint Foundation 2010 Service Pack 1 update process was incomplete, please perform the following steps:
- Confirm if the SPSearch4 VSS Writer is giving error.
A vssadmin list writers command will list the following vss writer as having failed -
Writer name: 'SPSearch4 VSS Writer'
Writer Id: {35500004-0201-0000-0000-000000000000}
Writer Instance Id: {ffdde2b3-5175-466b-87f7-3973278c7fbe}
State: [8] Failed
Last error: Inconsistent shadow copy - Confirm if the following event can be found in the Event Viewer -
Event Type: Error
Event ID: 70
Description:
The mount operation for the gatherer application GUID has failed because the schema version of the search administration database is less than the minimum backwards compatibility schema version supported for this gatherer application. The database might not have been upgraded. - Administrator can also run the following commands to determine if you need to complete the update process with PSCONFIG:
- Launch an administrative SharePoint 2010 management shell and enter the following commands -
>(get-spserver $env:computername).NeedsUpgrade
If the result of this command is True, please complete the update process with PSCONFIG.
For instruction, please refer to the Official SBS Blog:
http://blogs.technet.com/b/sbs/archive/2011/05/24/you-must-manually-run-psconfig-after-installing-sharepoint-2010-patches.aspx - Launch an administrative SharePoint 2010 management shell and enter the following commands -
If the problem persists, try stopping the SQL Server VSS Writer service and perform a full MS Exchange server backup manually via the AhsayOBM user interface afterward.
Figure 1.0 - Services (SQL Server VSS Writer)
If the SharePoint and SQL application are not used on the affected server, please disable all related services.
Also See:
http://blogs.technet.com/b/sbs/archive/2011/07/06/potential-issues-after-installing-sharepoint-foundation-2010-sp1.aspx
http://blogs.technet.com/b/sbs/archive/2011/05/24/you-must-manually-run-psconfig-after-installing-sharepoint-2010-patches.aspx
http://blogs.technet.com/b/sbs/archive/2011/05/24/you-must-manually-run-psconfig-after-installing-sharepoint-2010-patches.aspx
Other Info:
N/A
Comments
0 comments
Article is closed for comments.